Temporary Disruption: Donation Processing Unavailable on Support Page

Incident Report for BAI Studios

Resolved

This incident has been resolved. We appreciated your patience.
Posted Jul 06, 2025 - 20:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2025 - 19:30 UTC

Update

We are continuing to work on a fix for this issue. We appreciate your patience.
Posted Jun 29, 2025 - 18:52 UTC

Identified

The issue has been identified and a fix is being implemented
Posted Jun 29, 2025 - 12:36 UTC

Investigating

Our team is actively investigating the issue to restore donation functionality as quickly as possible. We appreciate your patience and support.
Posted Jun 28, 2025 - 21:14 UTC
This incident affected: API and Donation Portal.